Close

Not a member yet? Register now and get started.

lock and key

Sign in to your account.

Account Login

Forgot your password?

SOLVED: Cannot Install .NET 3.5 On Windows 10 Error 0x800F0906 and 0x800F081F

If you are running Windows 10 and need to install something old that requires .NET 2 or .NET 3.5 you will likely follow the instructions to install it from PROGRAMS AND FEATURES > TURN WINDOWS FEATURES ON OR OFF > .NET FRAMEWORK (INCLUDES .NET 2.0 and .NET 3.0) but then find you receive  errors like 0x800F0906 and 0x800F081F .  This is frustrating.  Fortunately the solution is simple IF you have a Windows 10 source disk:

You can install .NET 3.5 by bringing up a CMD window (don’t forget to right click and RUN AS ADMININISTRATOR) and then type either:

Dism /online /enable-feature /featurename:NetFx3 /All /Source:<drive>:\sources\sxs /LimitAccess

This has been a problem since Windows 8 and Microsoft really needs to fix it.  I have to do this command line install 100% of the time I need old .NET versions.

Share This With Your Friends Now:
Facebooktwittergoogle_plusredditpinterestlinkedin

  1. avatar
    André05-18-17

    It worked to me. Thanks a lot.

  2. avatar
    suresh01-25-17

    i need a Microsoft dot net framework 3.5 . Because i can’t download and install this framework.then
    error code is: 0x800F0906. please give a solution for this issue And i can’t do windows update. i installed windows 8.1 single language

    • avatar
      Ian Matthews02-15-17

      Does the command in the post Dism /online /enable-feature /featurename:NetFx3 /All /Source::\sources\sxs /LimitAccess not work for you?

  3. avatar
    Harry08-11-16

    thank you very much..it worked..dot net 3.5 installation issues with windows 10

Leave a Reply

Please confirm you are a person and not a 'bot' by answering this simple question: Time limit is exhausted. Please reload CAPTCHA.