SOLVED: IE11 Does Not Display Pictures, Just Placeholders and Flash Does Not Work

This is a train wreck of problem in IE11 that takes 3 seconds to fix.  If you go to sites like MSN.COM and find that many of the graphics have not loaded and/or you find that Adobe Flash content will not play the solution may be to disable PROTECTED MODE:

  1. Click the TOOLS cog icon in the top right corner
  2. Click INTERNET OPTIONS
  3. Click the SECURITY tab
  4. Uncheck ENABLE PROTECTED MODE…

ie11-windows10-not-displaying-pictures-protected-mode

I have seen this so commonly that I in companies that I work at I disable PROTECTED MODE using Group Policy.

windows-10-ie11-adobe-flash-does-not-work-loadYou may also notice that Adobe SHOCKWAVE Flash it NOT available when PROTECTED MODE is enabled.  Check

  1. Click the TOOLS cog icon in the top right corner
  2. Click MANAGE ADD-ONS
  3. Change the drop down to ALL ADD-ONS
  4. Look for SHOCKWAVE FLASH and you will probably NOT see it in the list unless PROTECTED MODE is disabled

 

Comments

  1. Avatar
    J. Trudeau (Le J Trudeau) November 21, 2019 at 9:47 am

    the problem I’m having is SOME images not showing in IE but do show in other browsers. Usually images that represent buttons or other page navigation “links”

  2. Avatar
    greg August 2, 2019 at 1:02 pm

    this fix also did not work for me. shockwave showed up and is enabled.

  3. Avatar
    Bob September 23, 2017 at 6:44 am

    Didn’t work for me. And Shockwave Flash does show up when protected mode is on.

    • Ian Matthews
      Ian Matthews December 28, 2017 at 11:31 am

      Hi Bob;

      I have seen this many times and it has always been the problem described in this article. If you find another solution, please let us know. We would REALLY like to hear about it.

      Thanks

  4. Avatar
    LookingforTHISsolution March 30, 2017 at 12:23 pm

    This has been driving me crazy – problem fixed, 3 seconds. YOU ROCK!

Questions or Comments?