SOLVED: Plantronics Mic Not Working on Mitel MiCollab Client

If you have a microphone that is not working on a Mitel MiCollab Client (formerly Mitel UCA) you likely have to remove the TELEWORKER GATEWAY setting.

Before making any changes, test your microphone is working by:

  1. click START and type SOUND
  2. Click SOUND (or do a dance through the control panel to find it)
  3. Click the RECORDING tab
  4. Speak into or tap the mic hard and see if the green volume bars  appear beside the microphone you are trying to use

Once you have verified your mic is working in Windows, turn OFF the Teleworker server setting in the Mitel MiCollab Client:

  1. Start Mitel MiCollab Client and log inno-audio-on-mic-not-working-plantronics-mitel-micollab-client
  2. Click the drop down arrow beside your name (in the top left corner of the Mitel MiCollab Client)
  3. Click CONFIGURATION
  4. Click SOFTPHONE SETTINGS
  5. Make sure your MICROPHONE device is set to the Mic you want to use
  6. UNCHECK the USE TELEWORKER FOR SOFTPHONE checkbox

This took a me 4+ hours to bang on before I called a Mitel tech on-site who spent another 2 hours working on before we found this.  Neither of us can explain why this setting needs to be removed in MiCollab 7.0 7.1 7.2 because it definitely did not need to be under the old Mitel UCA software.

You should also ensure that your headset is supported and supposed to work with Mitel MiCollab.  If you have a Plantronics headset the compatability guide will help:  http://www.plantronics.com/us/compatibility-guide/  Plantronics support on the other hand simply told me that if the mic works in Windows, it is not their problem and they have no capacity to troubleshoot Mitel software… arggg.

 

Questions or Comments?