Invalid Clipboard Format Error Partially Solved

We wrote our own bookkeeping software in Visual FoxPro many years ago and several weeks ago we found that when we print we receive OLE ERROR CODE 0X8004006a: Invalid Clipboard Format and the system outputs a blank page.

ole error code 0x80040006a invalid clipboard format

The problem occurs with soft printers like the MICROSOFT PRINT TO PDF and to hard printers like our Samsung C460FW, but only from this one app.  The printers all seem to function without error on other apps like Word, PowerPoint and Edge.

We don’t know what changed so we assumed the issue was related to Windows Updates (perhaps a driver update).  After a few weeks we had a few new Windows builds (we run on Windows 10 betas) we were frustrated to find the problem still existed.

We moved the program in question into a folder that was mirrored by OneDrive, then went to a new machine, signed in, synced OneDrive and found that the problematic program would print to Microsoft Print to PDF printer.  Naturally, we installed the Samsung C460FW and then immediately had the same INVALID CLIPBOARD FORMAT error.

We uninstalled the Samsung and found that we could again use the Microsoft Print to PDF printer.  So, the root cause would appear to be the Samsung print driver or port.  Back on our primary accounting systems computer, we removed the Samsung printer, the port and driver but still had the same error even printing to the PDF printer.

We decided to dig in hard and completely remove all of the print subsystems (printers, queues, software, drivers, driver files, ports) from the computer showing the error.  In fact this was so complete we decided to write up how we did removed the print systems.

Unfortunately, this did not solve the problem.  We still can not print from our accounting package on our primary accounting system, but we can print to a PDF on a secondary machine and then print that PDF (as long as the Samsung printer is not installed on that secondary machine).

This is an ugly work around so if you have any suggestions as to what else may be causing this problem, we would love to hear about it.

 

Questions or Comments?